Music oh Hold

Step 1: Under Service Param -> IP Voice Media Streaming Apps, set the supported codecs to “G711mulaw” and “729 Anex A”

Step 2: under Music on Hold Audio Source Configuration, Allow Multicasting

Step 3: Create a MoH Device Pool and add teh MoH Server to the MoH_DP
enable multicasting and set the multicast address to be the same as the Pub/Sub for easy ID e.g. 239.20.1.1
set Increment Multicast on IP Address
set the max hops optional

Step 4: Gateway Confiugration:

!
interface GigabitEthernet0/0.202
description **** Voice
encapsulation dot1Q 202
ip address 162.222.4.254 255.255.255.0
ip helper-address 162.201.1.22 redundancy 162.201.1.21

ip pim dense-mode

interface Loopback0
ip address 162.62.2.254 255.255.255.0
ip pim dense-mode
!
ccm-manager music-on-hold bind Loopback0
!
!
telephony-service
em logout 0:0 0:0 0:0
max-ephones 1
max-dn 1
ip source-address 162.62.2.254 port 2000
max-conferences 8 gain -6
moh music-on-hold.au
multicast moh 239.21.1.1 port 16384 route 162.62.2.254
transfer-system full-consult
create cnf-files version-stamp 7960 Dec 03 2010 05:24:38

 

Advertisements

CM to CUE Voicemail problem

scenario #
CM -> Gatekeeper -> CME -> CUE

Problem
When CUCM user calls CME User and reaches voicemail, the call fails. they get a fast busy tone.

I had a look to see whether it was transcoding, but it wasnt

CME#sh scc connections

Total number of active session(s) 0, and connection(s) 0
CME#

i came to the realisation that the incoming dial-peer was negotiating a codec,

!
dial-peer voice 2300 voip
translation-profile incoming in
voice-class codec 2
incoming called-number .

voice class codec 2
codec preference 1 g729r8
codec preference 2 g711ulaw

in this case it negotiated inbound to g.729.

Since CUE is g711, here it is supposed to invoke a transcoder, but it wasnt

when i removed the voice-class codec call was successful

dial-peer voice 2300 voip
no voice-class codec 2

In summary, i dont know if this is a bug or something, but once the codec has been “negotiated” the CME fails to invoke the transcoder. By removing the codec negotiation, the transcoder was invoked and call was successful

CME#sh scc conn
sess_id    conn_id      stype mode     codec   sport rport ripaddr

1          2            xcode sendrecv g711u   17806 2000  10.10.1.254
1          1            xcode sendrecv g729    18138 2000  10.10.1.254

Total number of active session(s) 1, and connection(s) 2

Inbound SIP calls on IPDCv3

This is just a summary of the changes that were made on your gateway to allow for calls and caller-id to work with you SIP service provider.

1.) Authentication
These additions were added to the gateway to allow it to register with the SIP Service Provider.

sip-ua
credentials username 00010### password ##### realm gw1.man1.theiptele.com
authentication username #### password ######realm gw1.man1.theiptele.com
retry bye 2
retry options 0
registrar dns:gw1.man1.theiptele.com expires 3600
sip-server dns:gw1.man1.theiptele.com

2.) Dial Peer
This is the dial-peer we use to match all inbound calls from your service provider. Because the service provider will be using one DID, I created this specific. In order to know how to manipulate the incoming or outgoing dial peer, I have included a document that discusses it below.

dial-peer voice 1000 voip
description SIP Provider
translation-profile incoming INBOUND-SIP
session protocol sipv2
session target sip-server
incoming called-number 442080900265
dtmf-relay sip-notify
codec g711ulaw

Dial Peer
http://www.cisco.com/en/US/tech/tk652/tk90/technologies_tech_note09186a008010fed1.shtml

3.) Voice Translation
In order to get the correct DID number and change the outbound attributes for calls, I used translation profiles. The inbound profile strips the 44 from the front of calls from service provider. The outbound profile changes the ANI number that goes to the provider.

voice translation-rule 1 (Incomming calls from provider)
rule 1 /44(2080900265)/ /1/
!
voice translation-rule 2 (Outgoing calls to provider)
rule 1 /.*/ /0001064781042/
!
!
voice translation-profile INBOUND-SIP
translate called 1
!
voice translation-profile test
translate calling 2

ephone-dn 6 dual-line
number 105 no-reg primary
pickup-group 100
label Emma
description Emma
name 2080900265
call-forward busy 200
call-forward noan 200 timeout 18
translation-profile incoming test

Translation Profile
http://www.cisco.com/en/US/tech/tk652/tk90/technologies_tech_note09186a0080325e8e.shtml

CLI: Quick CCME Config Commands

Obviously you gotta know what you are doing here but here are a list of commands to get CCME running (in no particular Order), and still adding …….

Ephone-dn———–

ephone-dn 12 dual-line
number 203
label 203
description 203
name 203
call-forward busy 6999
call-forward noan 6999 timeout 10

Static Route to SE————

ip route 10.1.10.1 255.255.255.255 Integrated-Service-Engine0/0

FXO ——————–

voice-port 0/1/0
no battery-reversal
cptone VE
connection plar 210

VM Dial-Peer———–

dial-peer voice 44 voip
destination-pattern 69..
session protocol sipv2
session target ipv4:10.1.10.1
dtmf-relay sip-notify
codec g711ulaw
no vad

TUI Login—————————

url services http://10.1.10.1/voiceview/common/login.do
url authentication http://10.1.10.1/voiceview/authentication/authenticate.do

Directory Entries—–

directory entry 1 # name Yusuf
directory entry 2 # name Rob

MWI—————-

ephone-dn 20
number 7000….
mwi on
!
!
ephone-dn 21
number 7001….
mwi off

Username?——————-

ephone 2
device-security-mode none
mac-address B8FA.8EE6.0002
username “brad” password 1234
type anl
button 1:12

Hunt————————–

ephone-hunt 1 longest-idle
pilot 5000
list 201, 203, 204
final 210
timeout 10, 10, 10

UC500 -> Cisco837 Internet Issue

Issue:
There si Internet connectivity from the Router but not from the UC500.
The UC500, however can ping the an external IP address

Solution:
DNS Issue, Add the DNS Servers under the IP Pools

(config)#ip dhcp pool data
(config)#dns-server <Server IP> <Server IP>
(config)#ip name-server <Server IP> <Server IP>